Your Second iOS and SwiftUI App · Challenge: Extract Subview |

This is a companion discussion topic for the original entry at

How do you go between files using a three finger swipe (01:52)?

You just need to set it up in System Preferences:

@jessycatterwaul Thanks. This gesture was set to “Swipe with tow fingers” at my Mac.

1 Like

Hello. I don’t have Extract Subview as well as many other choices. I am still using OS 10.14.6. Could that be the reason or is there something else I need to do? Thanks.


I can’t tell you for sure because I no longer have a Mojave installation, but it seems likely. SwiftUI previews were never available for Mojave so I never bothered trying SwiftUI with it.

Ok, Thanks. I can’t update to Catalina yet but when I do I’ll update.

I really don’t understand how a noobie like me who followed all the past courses was supposed to do this challenge without watching the solution. :frowning:

Thanks for the feedback. What do you think wasn’t adequately covered earlier in the learning path? We can try to smooth that out for the next course update.

Hello, Jessy!
I agree with brunomj1997. I can’t understand what is going on in this challenge. It is my first app with SwiftUI.
So, I created a RowView.swift. I extracted Subview from Text() in this file. But I can’t understand what is going on in ContentView.swift. It’s easy, if you know what you are doing =)

hey there, great tutorial as usual!
I have an issue , like [murf214] mentioned, theres no extract subview option on command click. Im on the latest os 10.15.1 . is it possibly an issue with the code? Any recomendations to get around the issue?

The only reason I know of, that that would happen, is if you don’t have the Canvas open. Did you close it?

I feel smart lol. Yea i keep it closed because the screen is so small. Thanks !!

1 Like

I’m also having the same issue with Extract View not showing up. Unfortunately, I am in 10.15.1. I reopened the Canvas and even waited until it rendered before giving up and just typing the code to match. If there’s some other trick I’d love to try and get this working. I think that if I could have found this menu item, everything would have worked great.

  1. What shows up instead?
  2. What shows up when you command-click on the canvas?

Feeling a bit sheepish… I realized the mistake was totally mine, for some reason I kept looking for Extract View, Extract Subview is totally there and works! I guess that’s what I get for trying to quickly finish this after a long day. Coming back after some sleep and all is good.

Thanks for getting back so fast!

1 Like

It may be because your file is in the wrong place.
I’m not sure but A must be next to the file.
I’ve had the same problem, but this is how I solved it.


How to you get the A?

That just means that a file has been added to your project but not yet committed to source control. Xcode letters beside files in Project Navigator - Stack Overflow

I really find this tutorial hard to understand :cry: :cry:
is it only me???