Stucked ... in chapter 9 : windows does not show anymore


Well, at the end of chapter 9 something happened …

I have this message and nothing shows.
2020-04-22 23:13:46.257088+0200 SceneGraph-macOS[7632:716851] CAMetalLayer ignoring invalid setDrawableSize width=2.000000 height=0.000000

I mean the App windows does not open.

I must have broken something somewhere


I was not able to fix it …
I restarted my Mac…

Now it is fixed.

Problem solved.

I am convinced it is linked to the memory of the size of the windows that was turned to a bad value. But I do not see were to fix that.

1 Like

Hey @behr,

Does opening the final scene and running it work?

It was the first thing I tryed.

I feel the issue I had but I cannot figure out how to solve it

The fact is that I reduces the windows size.height to 0. Xcode memorized that.
Rebooting solved the issue.

@behr Do you still have issues with this?

Oh yes (I thought I provided my answer earlier).

Issue was generated by a reduction of the application to 2 height.
Rebooting the Mac solved the issue…