Your Second iOS and SwiftUI App · Task Completion |

This is a companion discussion topic for the original entry at

Sending u a link of the video ! in the end when there is a editing view controller you will see that the app is crashed and nothing can be done from there!Dropbox - RPReplay_Final1570983361.MP4 - Simplify your life

This is the link of the project! Dropbox - File Deleted

By clicking this link you can download this project of mine

P.S. sorry its on russian language!

A .xcodeproj won’t work by itself. You’ll need to zip up the folder that encloses it so I have your files as well!

Is that will be fine?

No, that is still just the .xcodeproj package.

Could you please kindly tell me how to do it step by step please ? Because i am a beginner and i believe its not that hard?

This demonstrates what I’m talking about when I say “the folder that encloses it”. (1.7 MB)

I can’t get the app to crash. I did have to delete your LottieView though, to get the project to compile, as your JSON isn’t included (and because Lottie is outside the scope of the course). I am a little confused about what I’m looking for though. If you can give me a version of the project that doesn’t use Lottie, and is problematic, with a description of what’s going wrong, I’ll have another look!

I have a question. When I ran the app on the simulator at this point, I get the following message in the console when I switched the toggle switch:

2019-10-16 13:45:35.159887-0700 TaskList[58710:5050831] invalid mode ‘kCFRunLoopCommonModes’ provided to CFRunLoopRunSpecific - break on _CFRunLoopError_RunCalledWithInvalidMode to debug. This message will only appear once per execution.

I thought this might be my code so I tried the downloaded version. I saw the same message for the toggle switch so I don’t think there is an error in my code.

As an experiment, I tried to run this on my iPhone. I saw the same message above. Bun in addition, when I hit the button to go back to the Content View (< Tasks), the next warning came up:

2019-10-16 14:01:12.172141-0700 TaskList[5620:3121362] [TableView] Warning once only: UITableView was told to layout its visible cells and other contents without being in the view hierarchy (the table view or one of its superviews has not been added to a window). This may cause bugs by forcing views inside the table view to load and perform layout without accurate information (e.g. table view bounds, trait collection, layout margins, safe area insets, etc), and will also cause unnecessary performance overhead due to extra layout passes. Make a symbolic breakpoint at UITableViewAlertForLayoutOutsideViewHierarchy to catch this in the debugger and see what caused this to occur, so you can avoid this action altogether if possible, or defer it until the table view has been added to a window. Table view: <TtC7SwiftUIP33_BFB370BA5F1BADDC9D83021565761A4925UpdateCoalescingTableView: 0x10687a000; baseClass = UITableView; frame = (0 0; 375 812); clipsToBounds = YES; gestureRecognizers = <NSArray: 0x2821a5170>; layer = <CALayer: 0x282f711c0>; contentOffset: {0, -140.33333333333334}; contentSize: {375, 161.00000000000003}; adjustedContentInset: {140.33333333333334, 0, 34, 0}; dataSource: <TtGC7SwiftUIP10$1e0bee81819ListCoreCoordinatorGVS_20SystemListDataSourceOs5Never_GOS_19SelectionManagerBoxS2_: 0x10834e020>>

While this is only a warning, it seems important. Is this something to be concerned about? I am trying to get rid of it but need some guidance. Do you have any suggestions?



Hi Diane!

You’re the third of us to be involved in the conversation about this: Your Second iOS and SwiftUI App | - #2 by mseriff

My current feeling is “wait for the next beta and hope for the best”. But please let me know if you come up with better!

!!!Thank you so much! Seriously it was a problem of the lottie ! Thank you so much@@!!!

Amazing Course what are you doing for beginner developer is really so good! Thank you!!!

1 Like

Thats a great info! as Chokkaa mentioned above, its a good thing for beginner developers


Hi Jessy,
I don’t know if this is a bug or not, when i click one of the task, the EditView will jump up a little bit. It didn’t happened in your computer, i also runned the tutorial materials, but it still jumped. I tried many others ways but still not be able to solve it. My xcode version is 11.2, Swift 5.

@jessycatterwaul, when I click any row, then enter edit mode, then get back row gets disabled. No matter how many times I click it once again it has no effect. Meanwhile other rows remain clickable. When editing them further row becomes active again.
Could you please help.)

1 Like

I’m seeing the same problem with Xcode 11.3 and will log it with Apple. Hopefully the reproducibility means it will get fixed faster.

1 Like

Little late to the party. But Wow SwiftUI seems like I am learning iOS development again.

@jessycatterwaul I have a little issue on my app. onDelete is able to modify the model but that is not reflecting. First I thought I made the mistake typing it. then I copied contentView from this chapter to mine its identical.
Your Finished project able to delete the task from TaskStore and update the UI. Mine just delete from the task store. I dont see change unless I add the task then the old deleted task is gone.
Little confused where is the problem. Thoughts?
Currently, I have ContentView from this project and still the same issue.
whereas that same ContentView works fine in the lesson example view.

Hmmmm! :thinking: Not sure what might be the trouble without seeing the rest of your project; upload it and I’ll have a look!