Your First Kotlin Android App · Animations |

This is a companion discussion topic for the original entry at

At 02:37, you said “… will not return to original position before the animation”, which doesn’t make sense. Shouldn’t it say, “… will not return to original position after the animation” instead?

@rbondoc Can you please help with this when you get a chance? Thank you - much appreciated! :]

I have this issu after press button:

java.lang.RuntimeException: Unknown interpolator name: set
    at android.view.animation.AnimationUtils.createInterpolatorFromXml(
    at android.view.animation.AnimationUtils.loadInterpolator(
    at android.view.animation.Animation.setInterpolator(
    at android.view.animation.Animation.<init>(
    at android.view.animation.AnimationSet.<init>(
    at android.view.animation.AnimationUtils.createAnimationFromXml(
    at android.view.animation.AnimationUtils.createAnimationFromXml(
    at android.view.animation.AnimationUtils.loadAnimation(
    at com.wagnerrodrigues.timefighter.MainActivity$onCreate$1.onClick(MainActivity.kt:49)
    at android.view.View.performClick(
    at android.view.View.performClickInternal(
    at android.view.View.access$3600(
    at android.view.View$
    at android.os.Handler.handleCallback(
    at android.os.Handler.dispatchMessage(
    at android.os.Looper.loop(
    at java.lang.reflect.Method.invoke(Native Method)

My github repository : GitHub - wagner92sr/TimeFighter: App of RayWenderlich course

Issue solved.
the error was in this point : android:interpolator=“@anim/bounce”>
the correct code is android:interpolator=“@android:anim/bounce_interpolator”>

Hey there Folks!!!

I ran into a little hick up… hoping y’all can help a feller out… Okay so it goes like this… the below code was followed step by step from the video… butt… where it is typed view.startAnimation… the view text gives me an error “unresolved reference: view” okay so that’s a little hick up, but i would like to see the animation for myself, but can’t until the error is resolved… :sunglasses: :+1:

val bounceAnimation = AnimationUtils.loadAnimation(this, R.anim.bounce)


Just change view.startAnimaiton(bounceAnimation) with


and it should work.