Video tutorials are not playing

For example the following:

I have tried 3 different web browsers, rebooted, the ‘play’ button does not appear

This seems to be the same problem as this post from a few weeks ago. The play button does not appear

@katiecollins Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hi @um88,

I’m sorry you’re having issues here :[

Please could you try the following troubleshooting list to see if any of these help:

  1. Try a different browser and see if the issue persists.

  2. Is this with all videos or a specific video?

  3. Check to see if cookies are causing the problem. You can do this in Chrome by clicking File->new Incognito Window. Then sign in to your account and see if the videos will play.

  4. Check that JavaScript is enabled.

  5. Check for content-blocking plugins.

  6. Take a look at the JavaScript console for your browser. Take a screenshot of any errors (usually in red) and send them to us.

  7. Send us screenshots of what you are seeing if the above suggestions don’t resolve the issue.

  8. If you continue to have issues, please go to the link below and perform the internet connection test and then send us the results: Vimeo Player Debug

Please let us know by emailing us at if you try the above and are still having trouble. I’m so sorry for the inconvenience here!


@um88 Do you still have issues with this?

Hi I have the same problem, I just paid the subscription few days ago, and when I want to play any lessons there isn’t any play button at all, I can’t play all of the video content on the website. My chrome is up to date, I also tried on Safari, my java script is enabled, I cleared all the cookies and cache, I disable all of the plugins, please I need help.

Hi, I had the same issue and used the Brave Browser… works really well now!