Used dylib in my IOS framework getting error after App lauch

I have an embedded dylib in my IOS framework and trying use this framework in my application after launch is giving me an error.

dyld: Library not loaded:*.dylib
  Referenced from: /private/var/containers/Bundle/Application/43345D9E-F58D-4FBD-9C22-DD2554AE0484/*.framework/cocosdk
  Reason: image not found

.dylib is embedded in “Framework” folder in my IOS framework. things I’ve tried:

  1. install_name_tool -change oldpath newpath libname
  2. The framework already present in Embedded Binarie
  3. Present in Build Phases Copy Files to Framework
  4. Added Runpath search path as "@rpath/*.dylib", "@executable_path/Frameworks", "@executable_path/Frameworks/*.framework/Frameworks/*.dylib", "@rpath/Frameworks/*.framework/Frameworks/*.dylib"
  5. Added same path in Dynamic Lib install name
  6. Deleted all Derived Data
  7. Clean the project and tried
    8.‘Build Libraries for Distribution’ == true.

@shrinivasgutte Do you still have issues with this?

Hi @shrinivasgutte, what about trying to add the framework to the Frameworks, Libraries, and Embedded Content section under General? I apologize in advance if the #2 attempt of your list is what you were referring to.


This topic was automatically closed after 166 days. New replies are no longer allowed.