Problems access Tutorials due to privacy settings

Sorry if this is the wrong place to post this but I couldn’t find a better place.

I’m a new subscriber and have been digging into all the video tutorials, however, now that I’m traveling, I’m having trouble accessing them on my iPad. When I try to view one, the player shows a message that says, “Sorry. Because of its privacy settings, this video cannot be played here.”

I haven’t changed anything except for my location and traveling is often when I have the most time to use the videos. I should mention that I can play the videos on my Mac still, but if I try to watch them on my iPad, I get this message.

Does anybody know why this is happening and what I can do about it?


I am now also having the same issue. I cannot access the video tutorials… On my iDevices. Can you please advise?

Me too. Not the first time ocurred to me.

Log out and back in. I am guessing it is a cookie that tracks IP, and that has changed.

This is a known issue with Vimeo and Safari in iOS 9.3.1. It should be fixed in a future release of iOS. In the meantime, try watching on the Mac or with a different web browser:

1 Like

Good to know. Thanks for the response, Ray.

I also having the same issue…Thanks to all to your post.
Thank you.

Having the same issues for some videos in [Programming in Swift: Functions & Types] but only since the new design…(with Chrome & Safari)

Me too, also Firefox.

Hi @smicker & @c4lma,

I’m sorry you’re experiencing issues with this course. I have checked this out and it does seem to be working now - although you’re right it wasn’t earlier.

If you’re still having issues with this, please let me know which specific videos you’re not able to view.

Thanks so much for bearing with us!

Thanks Katie! I submitted a support ticket about 30 minutes ago with specific videos – are you able to access it?

Videos 41-45 still not working…

@smicker & @c4lma Ok - these two courses should all be working now - thanks for highlighting this and for understanding :]

@katiecollins I’m experiencing the same issue on videos 24-42 (except 36) in Your First iOS & SwiftUI App: Polishing the App too. I’ve tried on mac using latest version of Google Chrome.

Apologies, this is also fixed now. LMK if you have any further issues,


Hello @katiecollins , I am new member and also having some issues. For example [Advanced Swift: Protocol Oriented Programming] and [Beginning RxSwift] course’s videos are not working.

Hi @sarsilmaz I’m sorry for the inconvenience. Thank you for bearing with us!

These courses should now both be working.

Let me know if you have any more issues.


Hi @katiecollins , Thank you. First videos of courses are working but others are not. For example: Advanced Swift: Protocol Oriented Programming, Episode 2: Class Dispatch |, the new

I’ve cleared cache a few times and tried again but not helped to solve problem.

This is the console log that I am getting from Chrome: Uncaught (in promise) Error: An id or url must be passed, either in an options object or as a data-vimeo-id or data-vimeo-url attribute.
at getVimeoUrl (
at new Promise ()
at new Player2 (
at RWPlayer.load (rw-player.ts:69:21)
at (player_controller.js:41:19)
at Binding.invokeWithEvent (stimulus.js:281:25)
at Binding.handleEvent (stimulus.js:253:18)
at EventListener.handleEvent (stimulus.js:31:25)

Hey there, I was able to see the video - are you still having this problem?

Hey, unfortunately I am having same issue.

My Device: MacBook Pro (16 inch, 2021), macOS Monterey version 12.1, M1 Pro
My Browser: Google Chrome Version 106.0.5249.119 (Official Build) (x86_64 translated)