MrPig Chapter 19

On the part where I tap from SplashScene to GameScene I get the following error message:

-[MTLDebugRenderCommandEncoder validateFramebufferWithRenderPipelineState:]:1196: failed assertion `For color attachment 0, the render pipeline’s pixelFormat (MTLPixelFormatRGBA8Unorm_sRGB) does not match the framebuffer’s pixelFormat (MTLPixelFormatBGR10_XR_sRGB).’

I don’t get this error message on the simulator but only when I use my iPhone 8 plus. Does anyone know how to fix this issue? I can do fine any other tutorials but this only happen with Mr.Pig

Thanks in advance for your time.

@chrislanguage Do you have any feedback on this one? Thank you - much appreciated! :]

Hi there, the issue is related to an existing bug within SceneKit and Transitions while debugging. Please checkout this thread, there’s some ideas how to deal with the bug.

Thank You, I tried both workarounds but the only one that worked for me was editing the scheme. I noticed when the screen switches from the splash to the game scene there is like a 2 seconds green pixel moment then it loads the game scene. It’s pretty weird but hey it’s a work around, Thank You for the quick response.

This topic was automatically closed after 166 days. New replies are no longer allowed.