Kodeco Website Issues

Welcome to Kodeco! As we transition from RayWenderlich, you will probably find some quirks and features that aren’t working right. Please comment on those below, so that the right people can take care of them. Thanks!

Profile photo doesn’t render on top right menu, nor Activity list:

image

image

Issues

  • None of the dismiss buttons seems to work for me (x on a modal or banner). Tested on the Read the full story banner and bottom-right modal. I had to navigate to associated media for them to disappear. Tested on both Safari and Firefox.
  • If I login to another browser and navigate to a book I’m currently reading, it will clear the read status (which chapters I’ve read) of the book on the original browser.
  • Tapping on the Light-mode for the code blocks in books doesn’t do anything.

Suggestions

  • A detailed sidebar table of contents for books. It’s hard to navigate the page without one. This feature existed on raywenderlich.com
  • If I dismiss the contents sidebar, there is a lot of wasted space that has a show contents button
1 Like

Thank you for reporting! Will try to get things fixed up asap!

aaand avatars have returned!

2 Likes

FYI, the customize options for books don’t do anything. The text size only affects list items. Also, the TOC has no indication to what page you’re on.

I was hopeful that “classic” mode would bring back the old design.

Bit of an aside, but raywenderlich.com was one of the most pleasant reading experiences around, and one of the big things that drew me to diving into Real-World Flutter. It just felt good to read on desktop and my iPad - almost as pleasant as a real book, which is rare.

Not saying this just to be negative, as I’m sure there has been a huge effort behind this rebranding, but for me, personally, the new design is just painful to look at across the board. Aside from many small issues I’m seeing everywhere (menus sticking, borders improperly rendering, lots of font mismatches, awkward browsing experience, navigation items floating outside containers), the design at large just feels unbalanced and unpolished. I’m probably too sensitive to UX, but I don’t even know if I can continue with the book.

raywenderlich.com will be missed.

Am I missing the dark mode toggle or is there not one?

From what I understand, dark mode is still being worked on.

Doh! Not what I was hoping to hear but thank you for the info. Guess I’ll have to wear sunglasses until they get it implemented. :wink:

Very sorry about the issues you are experiencing — we are still working on improvements and bug fixes on the book reading experience (and other places, as you point out) — it’ll hopefully be back to its former (but new) delightful self soon.
(although, I’m sorry to say “Classic” will not bring back the raywenderlich style.)

My suggestions in the process of using the new UI:

  1. The red part I think should be fixed when user scroll down. Because of these features I use quite a lot in the process of learning
  2. The blue part allows the user to scroll down
  3. Dark mode is necessary in our world
  4. At home page should show which ebooks or videos the user is regularly accessing (like a quick access feature)
  5. In addition, if you want to close this pop-up, you have to scroll to the top and turn it off. Why don’t we fixed the Close button on top ?

Hope someone else has the same idea as me

1 Like

Thanks so much for taking the time to write out and illustrate the issues you are having, and sorry you are experiencing them.
Some of these issues are already being worked on, and should be fixed soon.

Could you elaborate on your 4th point — the home page already includes books, videos and learning paths you’ve last interacted with — how would your proposed quick access feature differ from that?

1 Like

Hi @jellodiil
At 4th) [Example for my case] I’m reading the book Combine: Asynchronous Programming with Swift
but you can see my home page doesn’t show it. Or I need to enable the “Recently” feature somewhere?

I see where you are coming from now.
I’ll log this request!

1 Like

Privacy settings aren’t selectable in Firefox on macOS. On https://accounts.kodeco.com/privacy, the choices are “Help make kodeco better…” and “Restrict usage tracking”. When I load the page, neither option is drawn as selected and neither option is selectable – click on either one in Firefox/macOS and nothing happens. In Chrome and Safari on MacOS selecting one or the other works as expected. I’m on macOS 12.6.1, latest versions of Safari, Firefox, Chrome.
By the way, one odd (broken) behavior that I’m pretty sure also existed on raywenderlich.com privacy settings page is that a first-load of the privacy settings page shows neither option as selected. If a user never selects either option, which is in effect? Is it tracking or restricting tracking? It’s got to be one or the other, right? I assume it’s tracking but neither is rendered on first load.
Thank you!

Thank you for reporting, and thank you for checking in multiple browsers.

Tracking is indeed the default, and should indicate as such.
Will get both issues looked at as soon as possible.

Hello @jellodiil ,

The code copy block seems have a very large border insets which overlaps the inner content:

Thanks, there seems to be some missing images in the WatchOS with with SwiftUI by Tutorials book. I reported this here: Missing image in Chapter 1+

Let me know if you want more info.

569de573fbe6a91b0e726f7146d8da2b7cdc3897_2_690x368

Thank you for reporting this! We’ll get on it!

Thanks for reporting — these should now be fixed!
Sorry about that.

1 Like