Heads up if you are on macOS Catalina -- bash is no longer the default

Not sure if this is my problem yet but when the author wrote this book, which is very good by the way, the default shell of OS X was forever and always ‘bash’. The default shell for any user account in macOS Catalina 10.15.x is ‘zsh’ which is different from ANYTHING it’s been for decades.

If you go into System Preferences → Users & Groups and ‘right click’ on your account name you will see ‘Advanced Options’.

Notice the RED warning. :wink:

This is where you can easily change your shell preference. I would strongly suggest you set it to ‘bash’ while you are working thru this book.

Happy coding!

This happened because of licensing conflicts between Apple and Bash. Give ZSH (the new default) a try, it was chosen in part because of the similarities with Bash.

When Catalina came out I thought I would give zsh a try. I had a few bash scripts that I was able to use with zsh with no modifications. I have just left the default to zsh and so far no issues.

This topic was automatically closed after 166 days. New replies are no longer allowed.