Hey there,
I think it will be more readable and convenient to use typealias in Chapter 8 code snippets:
public typealias ImageOperationCompletion = ((Data?, URLResponse?, Error?) -> Void)
That will be much more convenient to read and to code-when-reading