Chapter 23: Coroutines - starter fails to open

I cannot seem to get the starter file for Chapter 23 to run. Attached is a screengrab of the error I receive.

Any ideas for getting this up and running?

@galata Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hello @chuck_taylor, try to disable offline mode in Android studio preferences and run gradle sync with internet connection enabled. That way you’ll have a cached version on the plugin and it’ll work in the offline mode as well

Thank you @galata. The solution worked. I was doing the lessons on an airplane, and this one was the first one that gave me this error, and then would not shake it. Explicitly turning off offline mode worked.

Screen Shot 2022-01-25 at 2.40.58 PM
Hi I’m having trouble with the coroutines dep. And hence, importing the library. Check out my screenshots thanks!

Screen Shot 2022-01-25 at 2.42.54 PM

Hi @_iniubom! Have you tried the steps earlier in this thread yet? Do you see the same thing after following them?

Hi V, I think these don’t apply I’m using IntelliJ

Hi G,
I tried to toggle offline mode in gradle tab (upper far right in IntelliJ) , the error says disable offline mode and rebuild… After rebuilding, error: could not resolve our files for configuration 'compileClasspath
Thanks G.

Hi all.
I synced the Retrofit library…yet I received: unresolved ref kotlinx when importing, however auto complete works ‘Dispatchers. Default’ still red???

Checking everything to try to diagnose. Have you run a gradle clean, and invalidated your IntelliJ caches before restarting?

I invalidated cashes still the same how do you run clean Gradle?

∆∆ (。◕‿◕。)∆∆