Chapter 1 - Error: use of undeclared identifier 'NSTextView'

While working through Chapter 1, every time I try to modify the first breakpoint like so:

breakpoint modify 1 -c "(BOOL)[$rdi isKindOfClass:[NSTextView class]]"

I get the following error when the breakpoint hits:

Stopped due to an error evaluating condition of breakpoint 1.1: "(BOOL)[$rdi isKindOfClass:[NSTextView class]]"
Couldn't parse conditional expression:
error: use of undeclared identifier 'NSTextView'

Am I modifying the breakpoint incorrectly I wonder? If anyone has come across this issue and was able to resolve it, can you please let me know?


NSTextView is found in the macOS SDK, which is not to be confused with UITextView which is found inside the iOS SDK. Have you tried importing the AppKit framework? You could also try using the UITextView instead, and see if that solves your problem.

Here is a link that provides more information on the class:

Let me know if that helps!


Yes, that totally makes sense now that you mention it! I tried using UITextView and unfortunately that didn’t work… Entering expr @import AppKit though in the lldb DID work though! Thanks!

Thanks for your help answering that @syedfa

Anytime! I apologize if I stepped on your toes in any way :slight_smile:

@syedfa you didn’t at all. I appreciate and am grateful for it