Can't run the Kitura chapter 2 app within Xcode

I have followed the instructions in chapter 2 to create the Kitura server and have even downloaded the source but I get the same error. I can run the application from the command line and I can run the application within Docker but if I try to run the application within Xcode I get the following error.

dyld: Library not loaded: @rpath/agentcore.framework/Versions/A/agentcore

Referenced from: /Users/adrianbooth67/Library/Developer/Xcode/DerivedData/EmojiJournalServer-gkgotzcmfpswikgrtfudlrmihnag/Build/Products/Debug/EmojiJournalServer

Reason: image not found

Program ended with exit code: 9

I have updated brew without any difference. Clearly I want to be able to use the IDE within Xcode so am keen to understand what I am doing wrong.

I have the same problem! Dear authors of the book, please advice how can we run the app from Xcode. Your help will be greatly appreciated!

hi Denis and @adrianbooth67! The authors are IBM employees who have been redeployed, now that IBM is stepping back from Kitura.

I get the same error when I build and run in Xcode. This is probably an Xcode issue, which might resolve itself in a future release.

In the meantime, I think swift run in Terminal should work, whenever the book says to build and run. Please let me know if it doesn’t?


I solved this as I was opening the “package.swift” file in Xcode. I ran the following command in “terminal” and then opened the generated Xcode project and everything worked fine.

swift package generate-xcodeproj



1 Like

@denisthemenace Do you still have issues with this?

@adrianbooth67 Thank you for sharing your solution - much appreciated!