Build error in Chapter 2, First Project

I just finished SwiftUI Apprentice (well at least up to chapter 26 where the widget code was too outdated) and decided to move on to this book, Swift UI by Tutorials.

Opened the materials, Chapter 2, Starter project and straight away get a build error:
" Build service could not create build operation: unknown error while handling message: missing Target (guid: “96a35е3е49ca9187dfd59647efe277dace016658109a663a201c29bbef80d9”)

I cleaned the project, still does it. I restarted Xcode, still does it. I restarted my Mac, still does it. I tried a few other projects and they all work.

Then I realised this book hasn’t been updated in a while.

My question has two parts:

  1. Any ideas why I can’t even build / run the very first code sample?

  2. Should I be concerned at the lack of updates to this book considering I’m only just starting out on it?


hi Brett, I just downloaded the code and ran all 3 projects OK. I’m on an iMac with M1 chip, running Ventura. Xcode 14.2.

The other projects you tried are from the book? A StackOverflow post suggested deleting derived data or re-downloading from GitHub.

SwiftUI Apprentice update is scheduled for release next month. This book’s update is in progress.


Hi Audrey,

Thanks so much for the fast reply!

Doh, yep, deleting derived data fixed it. Thanks for pointing that out.

So glad to hear the updates are coming. I do love these style of books.