Beginning Firebase - Part 3: Configuring Firebase | Ray Wenderlich

Installing Firebase is not enough. You actually have to configure it in order to work with your app. In this video, you'll learn how to do this.

This is a companion discussion topic for the original entry at

@vegetarianzombie Brian. I just completed the steps from 3. Configuring Firebase. I am not getting any information in my debug frame one way or the other whether Firebase is working configured. Now, I just continued with my project from Part 2. Will that not work or is there some setting I need to do to make the Firebase status show?

Are you getting any information printed out to the console?

All I got was the following:

2017-08-22 13:56:31.753215-0600 Grocr[2845:141632] [MC] Lazy loading NSBundle MobileCoreServices.framework
2017-08-22 13:56:31.753791-0600 Grocr[2845:141632] [MC] Loaded MobileCoreServices.framework
2017-08-22 13:56:31.764034-0600 Grocr[2845:141632] [MC] System group container for path is /Users/XXXXXXXXXXXXX/Library/Developer/CoreSimulator/Devices/37313824-FF45-4C91-8DC7-4E2CDA2BD088/data/Containers/Shared/SystemGroup/

Is the configure call to Firebase being called? Did you put it in init or didFinishLaunching?`

When I had it in didFinishLauching, it looks like it was never called (I even tried a breakpoint on it and it never paused). That seemed odd to me.

Now I just moved it to an init, and I am getting a sigbart error stating that it cannot find the google config file.

I am going to try the steps again. Before I do though, can I simply start with my project from Part 2 or do I have to jump to the Part 3 starter project?

Yeah, it’s weird how Firebase reccommends didFinishLaunching when it doesn’t seem to get called. You should be fine with your Part 2 project. It sounds like all you need to do, though, is get the config file from Google and just import into your project.

Let me know how it works out. Thanks!

I have tried to follow the instructions and I am sure that I have added the plist file to the project. I have even tried doing the same thing to the 03 Final project. It is not working for me.

Perhaps there is a bug in the latest Xcode beta? I am using 9.0 beta 6.

Ok, I got it working, but I had to do it differently. I am going to assume there is a bug in Xcode 9 beta 6.

I copied my plist file that I downloaded, to the Crocr folder inside of Grocr. (not sure if that matters or not, but that is where it was located in the final project).

Then I used “Add Files to ‘Grocr’…” to add this plist file to the Supporting Files. (instead of drag and drop)

Build and Run and it worked as expected.

I had exactly the same problem. It appears that Xcod 9 beta 6 does not actually copy imported files from the location from which you choose to the project location. Once I had moved it manually to the Grocr folder inside of Grocr, my project built and ran OK.

Yes! Same problem. Here is the link to the StackOverflow question:

Hi . I had the same problem. By adding the

   override init() {

worked for me.

If you change the didFinishLaunchingWithOptions method to the definition below it does get called as expected:

func application(_ application: UIApplication, didFinishLaunchingWithOptions launchOptions: [UIApplicationLaunchOptionsKey : Any]? = nil) → Bool

Running xcode 9 (not beta) and this problem persists. I copied the plist file to the project folder in the Finder, then added it to the project via the File menu. Worked fine after that.

I know this is late but the command has been changed to: FIRApp.configure()
just wanted to save someone a google search.

This topic was automatically closed after 166 days. New replies are no longer allowed.