kodeco.com Forums

Accepting Credit Cards In Your iOS App Using Stripe

In this tutorial, you will to learn how to accept credit cards in iOS using Stripe, a pain-free, developer-centric way to handle purchases in your apps.

This is a companion discussion topic for the original entry at https://www.raywenderlich.com/182-accepting-credit-cards-in-your-ios-app-using-stripe

There’s someone who used this tutorial with firebase? I’m in doubt on how to create a function that fits properly with this code.

@lorenzoboaro Could you please help with this when you get a chance? Thank you - much appreciated! :]

@diegohv Thanks for your question. Unfortunately, I’ve not integrated Stripe and Firebase together. Are you encountering any specific problem? Thanks, Lorenzo

Thanks for the answer my friend. I actually managed to make it work with firebase following another tutorial and making sligthly changes in your integration code. It workd fine.

@diegohv Hello, do you mind if you share me the link for the firebase and stripe tutorial?? Thank you so much!!

Hi, I have followed the tutorial but when I charge the test credit card I get the following error:

Response status code was unacceptable: 402

Anyone know why?

Also, is the back end in this tutorial something we can put into our own app?

Thanks for your help.


I had the same issue. Here I described how I fixed it: How to fix Response status code was unacceptable: 402

Please, check

Great, great, great tutorial! Thank you :slight_smile: :clap:t2:

I have the same issue with the response status code as unacceptable and tried fixing it by making sure the TEST_SECRET_KEY is there before running the ruby script, but I’m still getting the same error. Any advice?

Nevermind, by looking at the logs in Stripe, I found out the currency was not getting there, and indeed, I was sending “currency:” instead of “currency” :man_facepalming:

@lorenzoboaro Can you please help with this when you get a chance? Thank you - much appreciated! :]

Hi , i followed your tutorial, but when i charged amount i got server could not connect.
can you help to how to solve this error?

Hi @bhumin! Thanks for your question. Are you able to provide more info about your problem? For example, do you have any problem running the server? What do you see on the terminal? Have you correctly setup the secret key? Thank you in advance.

Hi @jcabrera and sorry for the delay. Happy to see you fixed the problem :grinning: If you have any other question let me know. Thanks, Lorenzo

This tutorial is more than six months old so questions are no longer supported at the moment for it. Thank you!