Videos Not playing in chrome and safari

Even though I have a wifi Since yesterday I am unable to watch videos in chrome and safari is there any problem!.. Please let me know ?


I have the same problem on Safari (v. 10.1.2).
Yesterday everything was working correctly.
Thanks :).

some logs from console:
[Error] Cross-origin image load denied by Cross-Origin Resource Sharing policy. (x2)
[Error] Origin https :// is not allowed by Access-Control-Allow-Origin.
[Error] Failed to load resource: Origin https :// is not allowed by Access-Control-Allow-Origin. (playlist.m3u8, line 0)
[Error] XMLHttpRequest cannot load https :// due to access control checks.

Same here. facing this problem Since yesterday. I can’t watch any of your videos… (even though I’m subscribed).

Here is a console log from the browser:

Failed to load resource: Origin is not allowed by Access-Control-Allow-Origin.
XMLHttpRequest cannot load due to access control checks.

Same here. Some videos work but some are not…just spinning circle icon forever. For example: Beginner Collection View tutorial video doesn’t work. Another one is Unit test’s video 2: Test Basics. Seems like random videos are not loading.

1 Like

I too just got this, on .

Same problem here. I wasted the whole day due to this issue. I tried both my pc and mac. Same issue occurs. I hope RW team would put more effort on support as whole subscription based videos are down. We pay not to look at buffering video… Seriously they should figure out a pipeline to such issues so it wont’ happen again. Even if happens there should be a team to fix them up.

I have experienced the same issue on Safari 10.1.2. Its quite a strange issue considering the videos play perfectly on my iOS 10.3.3 iPhone. I have “Ask websites not to track me” disabled. :frowning:

me too, can’t play video .

I, too, am dealing with this problem of videos not loading. The loading icon appears, but nothing ever happens. I have tried this on Safari, Chrome, and FireFox and it does not work on all three.

Hi all,

Many apologies for the issues you’re seeing. They are caused by a CDN problem on the part of our video hosting solution. They’re currently working hard to get this fixed, and normal service should be resumed by the end of the week.

In the meantime I’ve just deployed a new version of the videos site that should allow you to watch videos again. The video player isn’t quite as fully featured as the one that you’re used to, but it will at least allow you to keep up with your courses.

Once again, please accept our apologies. If you are continuing to see issues then please don’t hesitate to reach out, either on these forums, or directly to our support team.



1 Like

Awesome! Thank you Sam. It worked for me.

1 Like

Thanks! Is there something different we need to do in order to view the new version? I am trying to view the Custom Collection View series.

Here is my current URL to the first video:


I simply refreshed the page and the new player was up.

My URL works for you, too?

Hmmm, strange, your URL didn’t work. It should. I was watching the MapKit Course and i simply refreshed and got the new player right away. :thinking:

Hmm. Maybe my course is propagating now…

I think so, it will probably be available soon.

Really annoying, just subscribed and I can view the free introductory videos fine but the subscriber content won’t play… Seeing 404 errors for vimeo links under Chrome.

There were a couple of additional problems with a few courses (including custom collection views) that I’ve now fixed.

Please let me know if you have any specific issues and I’ll investigate for you.


Thanks, Sam! It seems to be working now! Yay! :slight_smile:

1 Like