V3.0 / Chapter 2 - No such module RxSwift

the bootstrap.sh file is inside of each chapter’s RxPlayground folder.

Make sure you check “Build Active Scheme” and “Render Documentation” in the Plaground Settings (on the right sidebar)

I am having a problem that even with running boootstrap.sh on Chapter 3, I don’t get RxRelay . I even copied the build line for RxCocoa and replaced RxCocoa with RxRelay and it runs but I don’t get it. I don’t know enough about playgrounds yet to get this figured out


So if I hit BUILD enough times in Xcode it fixed itself with RxRelay chosen as the scheme. The first time I built that it did not seem to do it but I did it a few more times and the errors went awaty

The fix to this seems to be manually checking “Build Active Scheme”
Trust me, as authors, it is quite challenging following Apple’s yearly shenanigans and Xcode bugs :slight_smile:

Thanks for the notes.


That is generally the answer (mark the checkbox to Build Active Scheme" and the doc one above it. The chapter that had RxRelay I had to duplicate the xcode build line and substitute RxRelay as the scheme in the bootstrap script. And then build the RxSwift and then RxRelay schemes. That worked for me, though there may have been an easier way.

1 Like

Hello, I am having this issue. What exactly is checking “Build Active Scheme”?

My build settings of scheme looks like thisScreenshot 2020-10-21 at 22.38.12

I tried to do all the advices given in this thread but still the same result.
I really have no idea what to do to get this working. Can you please help?

Ok, I’ve finally noticed it. :slight_smile: This solved my problem:

Screenshot 2020-10-21 at 22.43.13


Thank you so much for finding a solution! I’m using Xcode 12 but this worked for me as well

Had the same issue with Xcode 12. Selecting “build active scheme” worked for me as well.

Just hoping this will help others in the future, this + build active scheme helped me too


I had to duplicate the xcode build line and substitute RxRelay as the scheme in the bootstrap script.

This worked for me

It’s really helpful, thanks

Hi! I already read all the threads concerning this problem but it does not seem to work with Xcode 12.3. When the project opens (Chapter 11 - starter) the error is “no such module ‘RxSwift’”. When I select “Build active scheme” the error changes to “no such module ‘RxCocoa’” which I did not manage to solve. Any help would be appreciated. Thanks!

I checked this on my old machine running Xcode 11.2.1 and it runs perfectly out of the box.

true, running with iPhone 8 simulator, finally. tricky solution, it works.

Thanks but it’s not working either :frowning: I think I keep on working with Xcode 11.2.1 :slight_smile:

solved my problem, really thanks.

Thank you. This worked!!

This worked for me too, Thanks!!

@jecht83 firstly check your cocoa pod version, make sure you have the latest version of cocoaPods installed, and then follow the given link it works for me. Enable build active scheme

I still don’t understand how to solve this problem for myself.
Xcode 12.5.1
Launched the script and checked the boxes

Снимок экрана 2021-07-02 в 13.59.34

But after ./bootstrap.sh clear
It all worked!

It worked for me, really thanks.