StoreSearch: can't place segmented control in navigationbar

I’m on p116 in the v4.1 tutorial in which we place a NavigationBar into the view controller and then are told to put a segmented control onto the navigation bar - on the title.

I can’t seem to do this. It always gets placed into the view or the tableview. If I try to drag within the outline, I can move it above or below the navbar, but it won’t let me place it IN the navbar even if I open the disclose triangle for the navbar first.

I just tried it and it works fine for me with Xcode 7.3.1. What version of Xcode are you using?

It may help to quit and restart Xcode.

I had to move the Navigation Bar to after the Table View in the outline. Otherwise the Navigation Bar is underneath I suppose, since the Table View occupies the entire size of the parent View. This allowed me to drag the control onto the Navigation Bar.


It still doesn’t seem possible to drag a control “into” another control using the outline view, however (at least not a segmented control into a navigation bar). I sometimes rely on the outline view when interacting with the storyboard layout is cumbersome.