Is there a naming convention that is being followed for flutter generally and for this book specifically?
I just started Ch.8 and found a number of variables prefixed with a small ‘k’ in the file ‘lib\navigation\app_link.dart’. I have not yet finished the chapter so this question may be answered later on in the chapter material.
Just got myself cleared out. This is known as Hungarian notation (HN) and the idea is to tell the type of a variable from looking at its name. so k stands for constant.
Taking things further, have a look at the Effective Dart styling guide. It is against the usage of the HN.
My suggestion to the editors and authors @spgms @mkatz @kevindmoore @jomoka is to adopt the style guide so learners apply it naturally through applying, altering and inspecting the book examples.
Following snapshot is from the style guide regarding the usage of prefix letters:
@rashidotm thanks we have this noted, and will be updated!