Kotlin Coroutines Tutorial for Android: Getting Started | raywenderlich.com

In this Kotlin Coroutines tutorial, you’ll learn how to write asynchronous code just as naturally as your normal, synchronous code.

This is a companion discussion topic for the original entry at https://www.raywenderlich.com/1423941-kotlin-coroutines-tutorial-for-android-getting-started

I just downloaded the project materials and opened it in Android Studio 3.5 on macOS.

Even though this article was published recently, all of its dependencies are very old versions - and not using any of the androidx libraries. The com.android.support.* libraries are deprecated and Android Studio will not build the project. AS shows this error message:

“Compilation is not supported for following modules: app, Snowy-starter copy. Unfortunately you can’t have non-Gradle Java modules and Android-Gradle modules in one project.”

What should I do to get this project to work in AS 3.5?

1 Like

I am having the same issue.

Thanks for the comments @mstralka and @richgabrielli! Sorry to hear you ran into trouble with the tutorial project.

Despite that error message, both the starter project and final project build and run successfully in Android Studio 3.5.

That error message re: “Unsupported Modules Detected” is an Android Studio project issue that does not affect the project being built, so you can ignore it. You can make it go away by re-downloading the tutorial zip files, then deleting the .idea sub-folder of the starter and/or final project before opening them in Android Studio 3.5.

With respect to AndroidX, I totally agree that it’s time to migrate to it based on Google’s recommendation, and most of our tutorials are using it now. But the support library 28.0.0 is still supported. You can switch the Snowy app to AndroidX by running the the “Migrate to AndroidX…” refactoring on the project in Android Studio 3.5; I did this and it worked like a charm.

Thanks again, and let us know if you have any further comments or thoughts!

Thanks for raising the issue @mstralka and @richgabrielli ! macsimus (Joe) is right the projects build and run successfully in Android Studio 3.5 . But still I have updated them with latest versions of dependencies and have migrated the projects to AndroidX.

Thanks again, do let us know if you run in any other issues.

Hi. I am running 3.5 and when I open the project and select run. I still get a lot of errors. Any help is appreciated.



Also, there is no .idea subfolder in either project.

Hey @richgabrielli I have just uploaded the updated project with migration to androidx. The error logs in the image seems due to the same . Please download the recent materials from the tutorial it should work.

Do let us know if it still get stuck somewhere.

Amanjeet Singh

Thanks @amanjeetsingh! That fixed it and I was able to run the starter. I will go through demo in the next few days!!! Thanks again for getting with me.


Hi Mr @amanjeetsingh
The First, I should say tank you for good article.
I try to write this sample like your sample but I have problem my sample works just one time.
That my mean my sample shows just one time picture when I click Tab or page between pages dont shows any picture and ProgressBar just shows.
Do you help me? what is my problem?

I would move the super class call to the end of the onDestroy method (see section"Cleaning Up")

The very first code snippet:
val snowyBitmap = getFilteredBitmap()

Shouldn’t this be showBitmap(snowyBitmap) ?

@amanjeetsingh Can you please help with this when you get a chance? Thank you - much appreciated! :]

I have used androdx with coroutines may be it might be helpful for you have a look

@ramesh1313 Thank you for sharing this - much appreciated!

This tutorial is more than six months old so questions are no longer supported at the moment for it. Thank you!