Intermediate iOS Debugging - Part 21: Wireless | Ray Wenderlich Videos

Learn how easy it is to debug without having to tether your device to your Mac.

This is a companion discussion topic for the original entry at

I can’t find “Connect via network” Item.

@jerbeers Can you please help with this when you get a chance? Thank you - much appreciated! :]

Yeah, it can be finicky for some people, especially if you’re using VPN, or something like that. There are several stack overflow pages with help troubleshooting these. Try unpairing and repairing your device, or rebooting both devices.

This article is talking about Apple TV, but the concepts work for iPhone and iPad devices too:

My Objective C project used to work fine until i installed Xcode 11. My Project works fine in simulator, But when installed in an iPad(iOS: 9) using Xcode 11.2 the app crashes in main.m( while loading a screen)
And i am not able to get any log in console.
ARC is enabled for the project.
Even adding exception breakpoint was not helpful.
I tried enabling Zombie Object in scheme, still i did not received any clue of the crash. Is there any way to get atleast a clue of what is happening?I am really confused because its happening only when i use xcode 11.2 to take the build to a ipad device.
only thing i know is the exception breakpoint has marked at
[ self.navigationController popViewControllerAnimated: NO];

It was a xcode 11.2 bug, which was solved when updated to xcode11.2.1.
The crash was due to uitextviewlayout. Only crashes when textviews are added via interface builder

@bon92 Really glad you fixed it! Cheers! :]