File Path Error from Using Templates

Doing Server Side Swift tutorial on RayWenderlich. Part 3, Templating with Leaf. Vapor Toolbox 3.1.10. Xcode 11.

Seeing this error when trying to open localhost:8080

{“error”:true,“reason”:“No file was found at path: TILApp/Resources/Views/acronyms8I_\u0000\u0001.leaf”

Looks like this is wrong /acronyms8I_\ and should be instead /acronyms\

No issues until it seems I started using base.leaf. I had been able to open the page, see the short long acronym, hyper links worked. I’ve tried building other projects in the tutorial. No help. (I also bought the ServerSideSwift with Vapor Book)

Debugging I see the path issue in TemplateRender.swift, public func render( _ path: String, _ context: TemplateData, userInfo: [AnyHashable: Any ] = [:]) → Future {

Though I have to debug again to see if the path is correct on the call or occurs in the function.

Using Vapor Toolbox 3.1.10. Xcode 11.

Of course I can access the API using Rested. Can add Users and create Acronyms,

When you do the view().render() call have you tried deleting that line and reading it? It looks like some weird characters have been added to that call