Errata for Flutter Apprentice 2nd Edition

Yes it is, nice catch, I didn’t notice it when I read that part :slight_smile:

There is a bug (reported here) that causes that error.
Maybe you reached the API rate limit but that API errors in response is not handled correctly.

Of course yes, they are set correctly, copied it from the edaman website

Chapter 13

Maybe you mean visible in your file?


Page 249
The text says “Locate // TODO 22: Add Row to group (name, date, importance) and replace
it with the following:”…
However, Row is missing from the following codes.

I signed up in the edaman website, I got a new id and key but it keeps giving same error :woozy_face::woozy_face:

Chapter 13 → Key points:

The highlighted point is not covered in this chapter, it is actually in the next chapter.


If you use the same credentials in the final project does it work as expected?

I just did that, same error :woozy_face:

Chapter 13 is where an “interface” for repository is created.
See section “Creating a repository”.

1 Like

Ok, it’s nothing to do with Edamam APIs. Does it work if you run the app in an emulator?

uh, I’m really sorry about that, I was totally lost because going back and forth between chapters. I’m following the book club at Flutter community YouTube channel, I read chapter 14 then 13 and because ch13 was too long, I thought the repository was introduced in ch14.
My bad :frowning:

anytime i try to connect to an emulator i created , my android studio will still say no device connected :unamused:

Hello iphie_flutter, I’m experiencing a similar issue. I tried to read through the comments but found no solution with reference to this problem. May I ask how you solved it? Thanks!

@houdini I haven’t sorted it out yet

Chapter 19: Anytime I try to sign Up I get this error, I don’t understand what it means by it couldn’t find the provider above the MessageList Widget. @funkyboy


This is my message_list.dart

The multiple provider is in the main.dart which is:

So which correct provider is it looking for???

The error message says it’s looking for the MessageDao. I don’t see that in your code. Just the UserDao.

13.5 Managing State in you App:

“But what happens if you create a model in that widget each time? That creates a new one! Any work that model did is lost the next time. By using create , Provider saves that model instead of re-creating it each time.”

Probably not an error, but after reading it three times I still don’t know what it is supposed to say.

@iphie_flutter It’s maybe a bug with the emulator, I don’t know. But you’d have to refresh the device drop down menu a couple of times before Android Studio detects the emulator.