Connect to a WebSocket |

This is a companion discussion topic for the original entry at

I am having trouble getting this to work:
When creating a new Vapor Server the resulting project structure is significantly different (e.g. contents of configure.swift). To follow along I tried opening the source materials, cd into the final/Server directory and ran vapor xcode -y.

Xcode then gave a warning that LibreSSL needed to be installed, so I ran: brew install libressl

I am stuck now with an error: 'openssl/conf.h' file not found

brew install openssl outputs: Error: openssl@1.1 1.1.1d is already installed

@pagemaster it looks like the server for this video uses Vapor 3, whereas a new project now will use Vapor 4 (this has only changed recently). Vapor 3 requires a few things to install so it can link to some sort of OpenSSL but if you do brew install vapor/tap/vapor3 that should install all the dependencies you need.

1 Like

When setting up the server instance via vapor new Server there is a questions Would you like to use Leaf?. Should we also mark “no” for this?