CLPlacemark not longer updating in CoreData after Swift 3 / Xcode 8 update


I’ve recently updated my project to Swift 3 iOS10 and after resolving some code changes it appears that CLPlacemark is no longer stored in SQLite database.

I’ve mapped it to Transformable object type, generated mapping and it looks following in Location+CoreDataProperties:
@NSManaged public var placemark: CLPlacemark?
However when I have connected to db and perform select on whole table the column appear to be null in every row. When in debug, just before performing save on context everything appears to be set all right. I’ve tried to read console output in SQLDebug mode but schema parameter 1
does not seem to work anymore.

Has anyone noticed similar behavior? I’m digging into documentation but there is nothing about it.

Yeah, the lack of debug output in Xcode 8 is a bit annoying. I don’t know an alternative for now but hopefully it will come back or some other method will be provided.

I’m wondering if CLPlacemark has changed in the way it supports NSCoding. Without that Transformable isn’t going to work. Have you tried testing encodeWithCoder(_:)/init(coder:) on the object? CLPlacemark is not listed as having changed in the iOS10 API diffs but you never know, maybe you found a bug.