Chapter 9 and 10 apps crashing with no error

Midway through chapter 9, when implementing the ProfileInfo composable, the app started crashing straight after launch, occasionally saying the “JetReddit keeps stopping”. I put this down to me doing something wrong, but I tried copying the Appdrawer file from the final project and still had the same issue.

I then tried opening the start project from Chapter 10, and it’s getting the same issue. There’s no build errors so I don’t know how to debug it.

I’ve had to update Gradle’s compose version to 1.0.0-beta07 for the code to compile, but other than that I’ve made no changes.

These are the emulator and Android Studio version I’m using:

Emulator: Pixel 4 API 30
Android Studio Bumblebee 2021.1.1

Any guidance is appreciated!

Tips to fix-

  1. Disable your antivirus.
  2. Disable the Firewall.
  3. Check the time & date.
  4. Reset the apps.
  5. Reset the Microsoft Store process.
  6. Clear Microsoft Store cache.
  7. Re-register ownership on Microsoft Store and Apps.

Rachel Gomez

Tips you provided seems to not work.
I am also experiencing this issue with chapter 9 and chapter 10 starter projects.
Android Studio just shows “Build Failed” and no error message.

Note: Since I am using newer version of Android Studio, I was asked to upgrade gradle when I run project.

Hello. Did you find solution to this issue?

Thanks, unfortunately even on a completely different machine (M1 Mac which shouldn’t have any of the AV/MS/Caches issues) I’m getting the same problem. This is from building the final Project #9, and updating some dependencies as suggested by Android Studio

  ext.kotlin_version = '1.6.10'
  ext.compose_version = '1.0.0'
  ext.compose_ui_version = '1.3.0-beta03'

So to answer your question @xudoyshukur , no I have not got it working :frowning: