Catnap not finishing curling

I’m not sure why, but at the end of Chpt 9 in Catnap the cat isn’t finishing it’s curl.

I have compared my code to the Final code and don’t see what is wrong.

Xcode Version 9.2 (9C40b)
macOS High Sierra 10.13.3 (17D102)

@spgms Thanks very much for your question! Have you tried running the sample code that the book comes with to see if it’s working as it should?

I added

catAwake.isPaused = false and catCurl.isPaused = false to the methods right after you set the position. That seemed to solve it for me!

Hope this helps :slight_smile:

1 Like

@syedfa, the sample code from Final doesn’t curl either, but picture in book does.

@paalmbr this worked in the simulator (iPhone 8 iOS 11.2), but not on my iPhone 7+ running iOS 11.2.1

Hi, same problem here. The sample code works fine, but my animations doesn’t start. I’ve tried to copy and paste the CatCurl.sks in my project and the code, but not even that way it works.

It doesn’t work for me either setting isPaused = false :expressionless:

If I set both (catNode.isPaused and catCurl.isPaused) to false, works fine :upside_down_face:.

This topic was automatically closed after 166 days. New replies are no longer allowed.