Beginning RxSwift - Part 1: Introduction | Ray Wenderlich Videos

Let's review what you will be learning in this course, beginning with a brief history of RxSwift.

This is a companion discussion topic for the original entry at

OMG! This course seems that is going to be really good, so excited, Thanks for your effort @scotteg :smiley:

1 Like

The playground don’t work, cannot get the Rx Framework to build in the playground, therefore, I get the following error. Tried all your suggestions, you have a whole section dedicated to helping get the Playground to work. This seems to be a fallacy as either Xcode is broken for these tutorials and you need to design better examples project that won’t fail, or I am somehow missing a step in the build process. I am a longtime iOS Dev and been using RxSwift in our production code for years, Why force Playgrounds with Cocoa Pods if you have to jump through a bunch of hoops for every example project? Playground execution failed:

error: Couldn’t lookup symbols:

@scotteg Can you please help with this when you get a chance? Thank you - much appreciated! :]

I solved the problem by adding these lines at the end of the Podfile and than running pod install again. It’a a known Cocoapods issue #7606.

  post_install do |installer|
      installer.pods_project.build_configurations.each do |config|