Beginning ARKit · Your First SceneKit Shape |

This is a companion discussion topic for the original entry at

Ran into a problem with simulating on my device. At first even though I got this message:
"Could not locate device support files.

This iPhone 8 Plus (Model A1864, A1897, A1898, A1899) is running iOS 12.3.1 (16F203), which may not be supported by this version of Xcode."

it still worked. But after the spaceship code was removed and the blue sphere code added, the app wouldn’t update and was still running the program with the spaceship. I then deleted the app icon off of my device.

When I built the app again and tried to simulate on my device, I again got the same message above, but now the app won’t even show on my phone.

Did some trouble shooting and came across a forum that suggested updating Xcode to the latest version and the IOS software as well. I have done both of these things and it is still not working. I also tried cleaning the build folder in Xcode.

Any suggestions or work arounds on this one?

Xcode Version 10.1 (10B61) - I believe is the latest I can get on my computer that is an older model. iPhone 8 plus, mac OSHigh Sierra 10.13.6

@accordionguy Can you please help with this when you get a chance? Thank you - much appreciated! :]