kodeco.com Forums

AWS Pinpoint Tutorial for iOS: Getting Started

In this AWS Pinpoint tutorial, you'll learn how to integrate Pinpoint SDK in iOS for app analytics. You'll also learn to add, upload, and analyze events.

This is a companion discussion topic for the original entry at https://www.raywenderlich.com/148-aws-pinpoint-tutorial-for-ios-getting-started

Nice :slight_smile:
More tutorial with AWS Mobile Hub please :slight_smile: :slight_smile:

I was expecting some AWS Mobile Hub tutorials on this forum.
Nice stuff on PinPoint !!

Anyone having issues importing AWS module onto AppDelegate? I tried everything under the sun to no avail.

@macandyp Can you please help with this when you get a chance? Thank you - much appreciated! :]


Sorry for the delay. I think you may just need to run pod install in Terminal, from your project’s root directory. Will you try that and let me know if that solved the problem?

Thank you for the response and I am sorry for my own delay (flu season got me out of commission for a few days). Unfortunately, I have tried pod install multiple times to no avail. To honor your request I did it again. Same: None of the AWS modules are recognized by my Xcode 9.2 running Swift 4 (in my case AWSMobileClient, AWSCore and AWSDynamoDB). Any other suggestions are appreciated.

Andy: It seems this is a targeting issue. When choosing to build the appName scheme Xcode does not identify any of the AWS modules and produces the errors. If I select the scheme Pods-appName, errors are gone. I am new to programming but I don’t believe I am supposed to build it for the pod-appName scheme but rather for the appName scheme, correct? Any suggestions?

That does sound odd. Have you tried quitting Xcode, clearing your Derived Data, run pod install and open the workspace again? If I download the sample finished project linked in the tutorial, and run pod install, everything builds as expected for me.

Andy, I followed your suggestion - thank you - and it moved me along a bit: I deleted the Derived Data, deleted the appName.xcworkspace and the Podfile.loc along with all the pods and ran pod install again.
This time, when importing AWS modules on the AppDelegate, it does list all the AWS modules, BUT now the for the imported AWS module reads “Could not build Objective-C module 'AWSMobileClient”. This has been a very long search…and it still puzzles me.

more interestingly yet, I ran a clean command and it all went back to not finding the AWS modules anymore: I am now back to "No such module ‘AWSMobileClient’ ". :face_with_raised_eyebrow::tired_face:

so far, as long as I don’t clean the product, the Modules remain available to the AppDelegate. If I clean it, they are gone until I build it again. Strange.

Is everything building for you now? I’m having a hard time replicating the issues.

Yes, as long as I do not clean it.
If I do, Modules are no longer accessible, requiring me to do a build first before they become available again, making all errors go away.
I should be able to manage the app to completion from here (or until the next obstacle)
Thanks for the help!

This tutorial is more than six months old so questions are no longer supported at the moment for it. Thank you! :]