Android Studios 2.0 error. Your CPU does not support required features (VT-x or SVM). What now

I need some serious help. I am a newbie android developer. I am trying to learn android so I can port some simple IOS apps I currently have on the Apple App Store. I got the following error below during installation. Where do I go from here? PS Feel free to chat with me about IOS stuff. I am an expert on all things IOS. Just learning android.

Unable to install Intel HAXM
Your CPU does not support required features (VT-x or SVM).
Unfortunately, your computer does not support hardware accelerated virtualization.
Here are some of your options:

  1. Use a physical device for testing
  2. Develop on a Windows/OSX computer with an Intel processor that supports VT-x and NX
  3. Develop on a Linux computer that supports VT-x or SVM
  4. Use an Android Virtual Device based on an ARM system image
    (This is 10x slower than hardware accelerated virtualization)

I don’t mean to bump my thread but I need some help. I have been an IOS developer for several years. Currently I am using an old Mid 2010 Macbook pro to create and maintain my IOS apps. I few months ago I tried to port some of my apps myself. I downloaded and installed the Eclipse software. I followed the beginning Android development tutorial here: Everything worked except the part with setting up an android simulator. I got several errors. One error stated that my Macbook doesn’t support Hardware virtualization, another error stated that only Intel processors are supported for emulation, a VT error etc. I was wondering if this is just because my Macbook is old. I know that a six year old laptop is very out of date. But at apple’s price point of 1,000.00 (1,300.00 now) that I paid for the Macbook in 2010 I plan to keep using it till it dies on my. Is there anyway way around these errors? Kindly reply or email me at or I know this is mainly an IOS developer blog but I am sure Andre99 isn’t the only person on this site that does both.

What version of Android Studio are you running? What version of OS X?

Run Software Update to make sure you have the latest firmware (per this Apple article).

Hope that helps!

check out this video, your cpu does not support vt-x or svm android studio solved