V3.0 / Chapter 2 - No such module RxSwift

Same problem on chapter 11, I can’t use the playground at all. No solution yet from RW…

after running ./bootstrap.sh also got same problem on xcode 10.2 no such module ‘RxSwift’

1 Like

It seems that the their default simulator was iPhone 8 which is not available in my simulator list. So I fixed it by adding iPhone 8 to simulator list :sweat_smile:

1 Like

I solved this problem. Open Xcode preferences and go to locations. There is command line selection, select Xcode version. Then its working :slight_smile:

1 Like

@jacquesj Do you still have issues with this?

I tried downloading the starter playground with RxSwift and RxCocoa added. But the link is no longer active. Can you kindly post a new link ? Thanks.

Your recommendation in Episode 3 - the nuke and repave option - became my last resort for getting pods to install RxSwift. It didn’t work but maybe you can spot something I missed. BTW, your tutorial on RxSwift is thoughtfully-presented with just the right amount of silence and no annoying music!

@greg_s Do you still have issues with this?

I was having this problem after updating to Xcode 12 but running ./bootstrap.sh clear and checking Build Active Scheme inside of Playground fixed my issue.

9 Likes

Thank you! It worked!

1 Like

Thanks. This is what worked for me.

How run ./bootstrap.sh
I have issue no such file or directory: ./bootstrap.sh

the bootstrap.sh file is inside of each chapter’s RxPlayground folder.

Make sure you check “Build Active Scheme” and “Render Documentation” in the Plaground Settings (on the right sidebar)

I am having a problem that even with running boootstrap.sh on Chapter 3, I don’t get RxRelay . I even copied the build line for RxCocoa and replaced RxCocoa with RxRelay and it runs but I don’t get it. I don’t know enough about playgrounds yet to get this figured out

11 Likes

So if I hit BUILD enough times in Xcode it fixed itself with RxRelay chosen as the scheme. The first time I built that it did not seem to do it but I did it a few more times and the errors went awaty

The fix to this seems to be manually checking “Build Active Scheme”
Trust me, as authors, it is quite challenging following Apple’s yearly shenanigans and Xcode bugs :slight_smile:

Thanks for the notes.

1 Like

That is generally the answer (mark the checkbox to Build Active Scheme" and the doc one above it. The chapter that had RxRelay I had to duplicate the xcode build line and substitute RxRelay as the scheme in the bootstrap script. And then build the RxSwift and then RxRelay schemes. That worked for me, though there may have been an easier way.

1 Like

Hello, I am having this issue. What exactly is checking “Build Active Scheme”?

My build settings of scheme looks like this

I tried to do all the advices given in this thread but still the same result.
I really have no idea what to do to get this working. Can you please help?

Ok, I’ve finally noticed it. :slight_smile: This solved my problem:

Screenshot 2020-10-21 at 22.43.13

26 Likes

Thank you so much for finding a solution! I’m using Xcode 12 but this worked for me as well

Had the same issue with Xcode 12. Selecting “build active scheme” worked for me as well.