Deploying to Vapor Cloud

Stopping the project fixed the issue for me.

1 Like

For me stopping the VPN fixed the issue.

1 Like

thank you! stopping the project solved it for me.

Thanks, it’s working now!

1 Like

I get the very same error:

$ vapor cloud create proj
project: TIL
Creating project ‘TIL’ [Failed]
Error: Cloud A P I Error: Could not connect to the remote API: Transport Layer Security Error: The TLS/SSL connection has been closed.
Identifier: TLS.TLSError.SSL_read (0)
Identifier: CloudClients.CloudAPIError.connect
Here are some possible causes:

  • The URL used is invalid
  • The remote API is currently not available

I am not using VPN.
I am located in Germany.

Any idea how to fix issue?


@whitestork26 have you got any instances of your Vapor app running whilst trying to do this? I’m not sure how on earth it makes a difference but it seems to

No. I restarted my Mac immediately before I tried to create the proj with terminal command: $ vapor cloud create proj

@0xtim : what further infos (log files, …) do you need to analyze the issue?
Thanks for any help!

@0xtim : I tried it again several times… for what reason ever… finally I could create a project. And the following steps worked fine.
App deployed to vapor cloud successfully.
Regards :blush:

Additional Info:
I did a complete new run through chapter 5 and created the TIL app for a second time, named it TIL2.

Again, when I run “vapor cloud deploy”, I get above mentioned error when I try to create a project in the guided procedure.
To get around the issue I entered the following in terminal: $ vapor cloud create proj. The second time it worked fine.
To go on with guided procedure of deploying stuff to vapor cloud, I entered in terminal again: $ vapor cloud deploy. This led me through all following steps.


@whitestork26 glad it’s working! Hopefully with the next version of the toolbox all these issues should go away