Chapter 12: Basic Animation Principles

Hey all,

I get the following error when starting the scene from a starter project for Chapter 12: /Assets/Scenes/Kitchen/LightingData.asset’. File may be corrupted or was serialized with a newer version of Unity.

My Unity Editor version is 2021.3.47.

@dover Can you take a look? Thanks!

Just wanted to check on this issue again. Is there anything that can be done?

Hi @matviienko Sorry I missed the ping on your original post!

I’ve just opened the project in the new Unity 2022 LTS and don’t see that error. That said, it’s just a lighting file, so if it is causing you trouble you can delete it, then open Window ▸ Rendering ▸ Lighting and then click Generate Lighting and it will recreate the file for you.

Thanks for your quick reply @dover. This solves the problem. Although there are no longer any compilation errors, I get a strange rendering of the scene, which looks like either a matter of a setting or my hardware. Please the screenshot attached. Any idea what might be the problem?

Oh, I think I know what your issue is @matviienko The assets in this project are stored in Git with LFS. Make sure you do a git lfs pull to get all the assets pulled down from git.

Oh yeah. That solved the problem. Thanks a lot for pointing it out @dover!

@dover I faced another issue related to the interaction. I can move Chef around with WASD but cannot Pick up ingredients using Space or Perform Wash / Chop action using Ctrl. Am I missing some settings?

Hi @matviienko In Chapter 12 you will first need to set up the animations otherwise it won’t really look like you are picking up or washing up / chopping. But if you get close enough to a trough and press Space, then an ingredient should be attached to your character if you then try to walk away. And if you walk to the sink and press Ctrl then you should be prevented from moving for a few seconds.

If it’s still not working, you can check the player input actions in Assets ▸ RW ▸ Scripts to make sure the inputs are set.

One last thing you can check is that the pickup zones are correctly set on the PlayerController also. The player needs to be close enough to one of these zones to make the Pick up action.


Hi @dover. Thanks a lot for tips. Everything seems fine. I checked the input mapping and the pick up zones. I did not log button presses when I came to the pick up zone but pressed space and it did not work. Please see the screen recording here: Screen Recording 2023-06-29 at - Google Drive

Very strange. Another thing to check is the Input Manager to ensure that the player input action asset is the one assigned here?

Also the troughs should be on a layer named “Interactable”

Do you have a controller you could try to see if the inputs are working from a controller?

Setting the layer for troughs to Interactable solved the issue. It was initially set to default. I completely forgot that I had the exact same problem when working through Chapter 6. Thanks again for help @dover!

1 Like