Ch 2. Observables - No such module 'RxSwift'

Hello. I am attempting to work through the examples in Chapter 2 but playground project cannot find the RxSwift module and I noticed there is no Pod directory in Xcode. I am using Xcode 11.3.1 and using the 3rd edition of the book. Here is a picture of my current setup:
image Screen Shot 2020-01-19 at 6.26.10 PM

I have followed the instructions in Ch. 1 and gone over them again repeatedly. As I understand, on pg. 42, for playgrounds the script should be enough to retrieve RxSwift and build to get running but I am not having such success. I have followed similar examples in the forum but to no avail. I also have cleaned and deleted derived data. Can anyone help me find a solution to this?

I believe, you did run, didn’t you?
And then run the project to build RxSwift?

@konic Yes I did. But XCode does not appear to pick up that RxSwift is there, so I am unable to access any of the entities of it.

@konic I also just noticed that I am not seeing RxSwiftPlayground scheme, just the RxSwift. Is this the possible reason or one of? If so, how do I rectify it?

  1. RxSwift scheme is should be.
  2. Did you look at V3.0 / Chapter 2 - No such module RxSwift - #2 by icanzilb discussion?
  3. What git version do you run?


  1. RxSwift scheme is should be.
  2. Did you look at V3.0 / Chapter 2 - No such module RxSwift discussion?
    I did but none of the solutions provided worked for me. Some of the users problems reflected my current experience but they did not get answered.
  3. What git version do you run?

@konic I some how got it working. Not sure what was the exact issue.

@fantomvii Did you solve this problem? I had the same issue, I fixed it just change target in scheme. I see you set RxSwift->My Mac , try RxSwift->iPhone 8 (this device set in run script)

1 Like

This worked for me, thanks.

This topic was automatically closed after 166 days. New replies are no longer allowed.